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Menu Functions

File menu

This group of menus handles all of the functions associated
with files or programs: opening, closing, printing, etc. Many
windows can be opened for writing and editing program
files, allowing you to work on multiple programs simulta-
neously without closing them.

new
Use this to create a new edit window for writing a program.
(An edit window, also called a program window, is a win-
dow where you can write or edit RESAMPLING STATS
programs.)  Selecting “new” multiple times will create
multiple empty windows.

open
Use this option to open an existing RESAMPLING STATS
program for editing. A dialog box will appear — you can
then scroll through available files. You can also move to a
different folder and/or drive. Double clicking on the file you
want (or clicking on the open button) will open the selected
file in an edit window.

close
Use this option to close the current active window — remove
the window and its contents from the screen. If you have
made changes since you have last opened the file or since
you last saved the document, RESAMPLING STATS will
automatically prompt you to save the document.

save
This option will save the contents of the active window
permanently to disk, retaining its existing name and updat-
ing its contents with the changes you have made. It will not
prompt  you for confirmation unless the document is new
and does not have a current name. In that case, it will ask
you for a new name.
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save as…
Use this option to save the contents of the active window,
but with a different name. This will allow you to make a
copy in order to make changes without destroying the
original file.

revert to saved
Use this option when you’ve made changes in a program file
and decide that you’d like to abandon the changes and go
back to the way the file was the last time you saved it.

print...
Selecting this option will cause the contents of the current
window to be printed. If the current window is the “graph”
window then the current graph will be printed on the
printer. Be sure that your printer is turned on.

Do not confuse the “print” option in the “File” menu with
the PRINT command used in a program. The PRINT
command in a program just tells your computer which
vectors to display in the results window. It does not cause
any output to go to the printer.

print setup...
Use this option to send various instructions to the printer.
For example, you can specify the orientation of the printed
page: landscape or portrait.

exit
Select this option to close the RESAMPLING STATS
program.

Edit menu

This menu provides all of the commands or options avail-
able for editing a program. The editor is a full screen editor
where the mouse is used for positioning the cursor and
selecting or highlighting text. The commands that are essen-
tial for editing are described below:

copy
Use this to copy a block of text. First, use the cursor to select
the block of text you want to copy. Then select Copy. This
duplicates the current highlighted selection and places the
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duplicate on the clipboard. (The “clipboard” is a hidden
“parking place” where sections of text are temporarily
placed when they are in transit.)  The original selection is not
affected.

Then move the cursor to the position where you want to
copy the material and use the “paste” option.

Keyboard shortcut: Hold the control key while pressing C;
this copies a selected block of text to the clipboard.

cut
Use this to either remove or move a block of text. First, use
the cursor to select the block of text you want to remove or
move. Then select “cut.” This removes the current high-
lighted selection from the “edit” window and places it onto
the (unseen) clipboard.

If you are moving (as opposed to removing) a block of text,
move the cursor to the position where you want to move the
material and use the “paste” option.

Keyboard shortcut: Hold the control key while pressing X;
this removes a selected block of text and places it on the
clipboard.

paste
Use this to insert the text that you want to copy or move.
First, move the cursor where you want to place the text.
Selecting “paste” duplicates the current clipboard informa-
tion and inserts it at the current cursor position. If you have a
block of text selected and highlighted when you use “paste,”
that block will be replaced with the clipboard selection being
pasted.

Keyboard shortcut: Hold the control key while pressing V;
this “pastes” the clipboard contents to the current file wher-
ever the cursor is.

clear
This removes the current selection but moves nothing to the
clipboard. The current selection is lost.

select all
This option will select all of the text in the current active
window.
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preferences
This option allows you to change several default settings:

explanations

In addition to the “hints” at the bottom of the screen, various
help messages appear at different points in the operation of
RESAMPLING STATS. You can elect to have either long or
short explanations.

color
Use this to set your desired foreground and background
colors.

list source...
Use this option to have RESAMPLING STATS include your
command statements (your “source code”) in the results
window.

create backup
Use this option to have RESAMPLING STATS automatically
create a backup file for each program file that you save.

max histogram…
Use this option to change the maximum number of “bins”
that the HISTOGRAM uses. (A “bin” is a range of values
included in a single histogram bar. For example, a histogram
bar centered around the value 5 might include values from 3
to 7. This bin’s center is 5 and its width is 4.) When the
HISTOGRAM command draws a histogram, it first calcu-
lates the number of bins required to draw a reasonably-sized
graph. It will not exceed the number specified in this option
(set by default at 20). You can increase or decrease the num-
ber of bars in the histogram by altering this value.

check for escape
RESAMPLING STATS allows you to halt program execution
with the escape key, which requires the program to con-
stantly check to see if the escape key has been pressed.  To
speed execution, you can tell RESAMPLING STATS to skip
this step, in which case pressing escape while a program is
running will have no effect.
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Run menu

This menu provides all of the commands or functions for
running a RESAMPLING STATS program. You are ready to
run your program after you have finished typing in your
RESAMPLING STATS commands. If the execute or step
options are not selectable, then an edit window needs to be
opened or made active first.

NOTE

There must be a set of RESAMPLING STATS commands in
an active edit window before RESAMPLING STATS can
execute anything. If you have multiple “edit” windows
open, the current active window’s program will be the one
executed. So make sure the “edit” window you want to run
is the front-most window. This will be the active window.

check
Use this option to check your program for errors. Keep two
things in mind:

1 Some errors might not emerge until you actually run the
program.

2 An error-free program is one that will execute properly
without producing error messages. It does not necessarily
produce a statistically correct answer.

clear output
This option closes the “results” and “graph” windows,
erasing those results.

execute
Use this option to execute or run the program in the active
“edit” window. If your program is error-free, the results will
appear in the “results” window. If your program has errors,
RESAMPLING STATS will describe the problem and give a
descriptive error message that will appear in the “error”
window.

You do not have to save your program before you run it, but
it is recommended that you do so to ensure that your up-
dates will have been saved in case of some unforeseen
problem.

If a PAUSE instruction is encountered, the program will
stop executing. Selecting the Execute option again will
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Wizards menu

cause the program to continue with the next statement after
the PAUSE.

NOTE

To print your program, make sure the “edit” window is the
active window and choose Print from the “File” menu.  To
include your program commands in the “results” window,
select Preferences  from the “Edit” menu and make sure
the “List source in results” option is selected.

step
This option will execute one command at a time starting at
the current command. In this way you can “step” through
your program one command at a time and see the results as
your program executes. You must click on the desired vector
to see what’s inside it. A maximum of 100 values will show
in the Step dialog box.

HINT

Use the Step option to “debug” your program — i.e. to make
sure it is doing what you think it is, one step at a time.

Use RESAMPLING STATS Wizards to simplify the task of
writing programs.  Write one iteration of the procedure in
the RESAMPLING STATS language, then use the Wizards to
repeat it and analyze the results.

Here’s how:

Let’s say you want to find out how probable it is that you
will get 14 or more heads in 20 tosses of a fair coin.  There
are 3  basic steps:

1 Write a “core procedure” (in this case, flipping a coin 20
times and counting heads)

2 Repeat this core procedure lots of times and record the
outcomes (the number of heads each time)

3 Analyze the results to see how often you get 20 or more
heads
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Using the RESAMPLING STATS “Wizards” menu:

1 From the “Wizards” menu, select “Write Core Procedure.”
A blank window (called a “program window”) will open
up.

2 Click on this blank program window to make it active,
then type the following:

GENERATE 20 1,2 flips

COUNT flips =1 heads

This will generate, at random, twenty “1’s” or “2’s” and put
them in a vector called “flips.”  (A vector is just a list of
numbers.)  We’ll let “1” = “heads.”  Then it will count how
many “1’s” there are in “flips,” and put the result of that
count into “heads.”

3 From the “Wizard” menu, select “Check Core Procedure”
to make sure your commands are typed correctly.

4 From the “Wizards” menu, select “Repeat Wizard,” and
answer the questions.  You can leave the “number of
repeats” at 1000.  The vector you want to keep track of is,
of course, “heads.”  You can name the scorekeeping vector
anything with 8 characters or less; we suggest “scrboard.”
Then click “proceed” — RESAMPLING STATS will then
repeat your commands 1000 times and record the results
of each trial in the vector “scrboard.”  “Scrboard” now
contains 1000 numbers, each number representing the
number of heads in a particular set of 20 tosses.  Note how
RESAMPLING STATS adds the necessary commands to
your program to accomplish this.

5 If it is not already open, from the “Wizards” menu, select
“Results Wizard,” and answer the questions.  We are
interested in analyzing the results in “scrboard,” so leave
that as is in the first line.   Our original question was about
the probability of getting 14 or more heads, so, in the
second line select >= (“greater than or equal”), type in 14,
and select “get results.”  The answer will appear in the
panel on the right. This is the estimated probability of
getting 14 or more heads in 20 coin tosses.

Note how the Repeat Wizard adds the REPEAT/END and
SCORE commands to your program (as well as the HISTO-
GRAM command if you had that box checked).  As you get
more proficient with RESAMPLING STATS, you may choose
either to continue using the Wizards, or to write your pro-
grams entirely from scratch.



15Menu Functions

Windows menu

Use this menu to “bring to the front” RESAMPLING STATS’
windows. Selecting any window from this menu will auto-
matically make it the active window, covering up other
windows behind it. This is very useful if there is a window
hidden by other windows.

You can also make a window active by clicking on it, if it is
visible.  A window must be active before you can enter data
or text in it, run the program in it, or print its contents.

“edit” windows
These are windows where you edit (write) your program(s).
In the “Windows” menu, these windows are listed by name,
above the dotted line.

The open “edit” windows are listed by title above the line in
the “Windows” menu.

“error” window
This window is where any error messages will be displayed.
If the “error” window is not currently visible and the pro-
gram encounters an error, the “error” window will automati-
cally be displayed. A checkmark to the left of the “error”
window name in the menu indicates that the “error” win-
dow is open on the screen. (It is considered open even if
other windows totally hide the window.)

“results” window
This window is used for showing output from the programs.
This includes output from any PRINT command(s), fre-
quency tables from HISTOGRAM commands and any other
message except for error messages.

To print the output from your program (the results, for
example), make sure the “results” window is the active
window and choose print from the “File” menu. To include
command statements in the printout, choose list source in
the preferences option (under the edit menu) before you
run your program.

Do not confuse the Print option in the “File” menu with the
PRINT command used in a program. The PRINT com-
mand in a program just tells your computer which vectors to
display in the “results” window. It does not cause any
output to go to the printer.
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“graph” window
This window is where histograms and other graphs are
drawn. This window is normally invisible; if the program
encounters one of the graphing commands the window will
be made visible automatically. The scroll bars and size box of
the window allow you to see the entire graph.

If you have specified more than one vector to be graphed in a
single command (HISTOGRAM y z), use the horizontal
scroll bar to see all of the graphs.

Scaling: graphs will be scaled automatically according to the
maximum and minimum values of the variables.

In histograms, the left side of the graph — the y-axis —
indicates the frequency count of the vector elements, while
the bottom of the graph — the x-axis — displays the variable
values.

You can control the number (and hence the width) of the
histogram bars through the “preferences” option in the
“Edit” menu — see above.

To print the “graph” window, simply make sure it is the
active window and choose “print” from the “File” menu.  Or,
to have better control over the size and appearance of the
graph, copy it to your word processor and print it from there
(while the graph window is active, select “copy” from the
“Edit” menu).

“hints” window
This window contains general explanations pertaining to the
situation you are in.

Help menu

RESAMPLING STATS offers you lots of help. Through the
“Help” menu, you can get:

• “Help topics” — A list of subjects on which further help is
available.

• Introduction and examples in the “getting started” and
“examples” sections.

• Help with commands
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Other help includes:

• A “command syntax checker” at the top of each “edit”
window that tells you whether you’ve typed a valid
command, what additional information the command
needs, and whether you have entered all the information
properly.

• Control-F1 gives you help with the command on the
current line.

• Shift F1 gives you additional context sensitive help.


